ImportError: /lib64/libstdc++.so.6: version ‘CXXABI_1.3.8’ not found 的解决办法 (已解决)

1.先查看当前Linux服务器gcc版本中包含哪些库。(注意:要区别当前Linux版本是32还是64,下面的操作是查看64的,下载文件也需要用64)
strings /usr/lib64/libstdc++.so.6|grep CXXABI

CXXABI_1.3
CXXABI_1.3.1
CXXABI_1.3.2
CXXABI_1.3.3
CXXABI_1.3.4
CXXABI_1.3.5
CXXABI_1.3.6
CXXABI_1.3.7
CXXABI_TM_1

2 下载 libstdc++.so.6.0.24 文件。

3 进入/usr/lib64/目录下,删除(rm -rf libstdc++.so.6)或者重命名(mv libstdc++.so.6 libstdc++.so.6.bak)libstdc++.so.6,然后执行ln -s libstdc++.so.6.0.24 libstdc++.so.6重新构建动态库libstdc++.so.6

4 最后strings /usr/lib64/libstdc++.so.6|grep CXXABI 查看是否成功

赞(1) 打赏
特别声明:除特殊标注,本站文章均为原创,遵循CC BY-NC 3.0,转载请注明出处。三伏磨 » ImportError: /lib64/libstdc++.so.6: version ‘CXXABI_1.3.8’ not found 的解决办法 (已解决)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏